Editing Tables

Use GemFire XD.NET Designer to visually create and modify GemFire XD tables.

Prerequisites

Before you follow this procedure:

Procedure

To design GemFire XD tables with GemFire XD.NET Designer:
  1. Start Visual Studio 2010.
  2. Select View > Server Explorer to open the Server Explorer window.
  3. Expand the Data Connections > GemFire XD node.
  4. To create a new table, right-click the Tables folder and select Add New Table to open the Table Designer.
  5. To edit an existing table, right-click an available table name and select Design to open the Table Designer:

  6. The Table Designer view provides several features to help you edit GemFire XD tables:
    • Column editor grid—Use the column editor grid at the top of the view to add, delete, or rearrange table columns. Enter column names and data types directly in the labeled cells. Choose Allow Nulls if the column should allow null values.

      Click the cell to the left of a column to select the entire column, or drag the cell to the left of the column up or down to rearrange columns.

      Right-click in the cell to the left of a column to access the column's context menu (for example, to delete a column or display the Properties window).

    • Properties window—Use this window to edit the name and schema of the table.
    • Table Designer menu—Use this menu to perform editing tasks such as adding and deleting columns, setting the primary key column, editing indexes and primary keys, editing foreign key relationships, or editing check constraints:

  7. Select File > Save table-name or File > Save All to save your changes.
  8. When creating a new table, GemFire XD.NET Designer prompts you to enter a table name. Specify the schema and table name, separated by a period (for example, APP.Table1).